Sanderling High CPU Load


#1

Hello,

when trying to run Sanderling (latest Version), after selecting the correct process the CPU-Load goes to 100% load and it takes about 25 Seconds to get the “last measurement”. After this, it takes again about 30 Seconds to update, all while take up to 90% of the CPU-power and running at 100%

I have an I7 8700k, so this should not be any problem.

Any idea why I run into these Problems?


#2

Such thing was when i modified script the way when it goes to infinite cycle.


#3

Not yet, but I will take a look at this today.


#4

Such thing was when i modified script the way when it goes to infinite cycle.

Mmh, good to know. Basically I have a script that runs an “infinite” cycle in a while-case, but I have sleep-timer between the cycles.
Also don’t get so far to start any script yet, I’m still in the “basic” process after the process-selection.

Not yet, but I will take a look at this today.

Awesome, just tell me if I can help any way.


#5

Thank you for clarifying it is not dependent on starting a script.

I have run a test here with Sanderling version 2018-05-03, with the eve online char docked in station:
I do not see anything unusual, the memory measurements take between 240 ms and 270 ms.

Since you mention 100% CPU load with your setup: I would be surprised if the memory measurement code uses more than one thread. So no matter how long it takes, it should only max out one CPU core at most.


#6

In my case, Sanderling uses all CPU-cores out to maximum.


#8

Deleting every setting / folder and setting up in a new folder did solve the problem for me. So there must have been some issues with the installation i cant explain myself.

Anyways, thanks for the fast support @Viir !