Sanderling release v16.03.09

release
sanderling
bugfix

#1

Improvements since v16.03.04:

  • fixed a bug which could stop the script execution
  • added parsing of Ship UI indication.
  • changed included auto pilot script to not open the menu anymore while warping or jumping.

#2

This version will not undock for me.  Mouse moves close to the undock but never activates it.


#3

This version will not undock for me.  Mouse moves close to the undock but never activates it.

Can you take a sample for me as described in that thread? http://forum.botengine.de/thread/collecting-samples-for-memory-reading-development/

With that data I could look into the structure of the memory to adjust the memory reading code.


#4

I will attempt to capture the memory as requested.  I managed to get undocked by repeating the undock request as follows:

 void Undock() {     while(Measurement?.IsDocked ?? true)     {         Sanderling.MouseClickLeft(Measurement?.WindowStation?.FirstOrDefault()?.UndockButton);         Host.Log("waiting for undocking to complete.");         Host.Delay(8000);      }           Host.Delay(4000);     Sanderling.InvalidateMeasurement(); }

Now the interesting thing is sometimes it gets it first try, but sometimes the mouse will move around the square that is the undock button, then eventually get to the middle.


#5

Sometimes does not exit from hangar. I use additional keys in the client settings. eg "LCtrl + Q".

void Undock(){ Sanderling.KeyboardPressCombined(new[]{ VirtualKeyCode.LCONTROL, VirtualKeyCode.VK_Q});
Host.Log("жду завершения выхода из станции.");
 while(Measurement?.IsDocked ?? true) Host.Delay(1111);
Host.Delay(4444);
 Sanderling.InvalidateMeasurement();
}

#6

I am starting to see a lot of incorrect module reads.  I have two strip miners filled and sometimes it discovers both.  Sometimes just one,  Sometimes none.  When it discovers none I sit out in the astroid belt forever.  Not sure if it is related to the undock button issue.


#7

I am starting to see a lot of incorrect module reads.  I have two strip miners filled and sometimes it discovers both.  Sometimes just one,  Sometimes none.  When it discovers none I sit out in the astroid belt forever.  Not sure if it is related to the undock button issue.

I would like to try to filter out the incorrect reads of the ModuleButtonTooltip. For this I need a sample of the data on the bot API "MemoryMeasurementAccu" property at the time when a module (better both) is not recognized as expected.

The gif below shows how to export the snapshot:


#8

Hello,

Something is wrong with licence service, becouse Sanderling cant connect with it. Im using 16.03.09 version  with this http://service.botengine.de:4074/api .


#9

Hello,

Something is wrong with licence service, becouse Sanderling cant connect with it. Im using 16.03.09 version  with this http://service.botengine.de:4074/api .

Yes, there was an unplanned downtime today. It works now.


#10

Where is this snapshot file saved?


#11

It is saved to the file which you drop on the file button.


#12

thanks for the info … i am hoping to find further information of what conditions can be seen given the memory measurement.

I goto drop file on file button and just get the circle with line through it.

nvm … cannot run app as administrator to copy file …